Login and trades

Incident Report for Swyftx

Resolved

This incident has been resolved.
Posted Jul 12, 2026 - 10:29 AEST

Update

The system is now stable, and we are continuing to monitor the results.
Posted Jul 11, 2026 - 06:08 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 11, 2026 - 05:10 AEST

Update

We are continuing to investigate this issue.
Posted Jul 11, 2026 - 04:43 AEST

Investigating

Some customers may be experiencing login issues, and some trades may also be impacted. We’re investigating and working to restore access as quickly as possible.
Posted Jul 11, 2026 - 04:43 AEST
This incident affected: Trading Website - trade.swyftx.com.