AUD Withdrawals Impacted
Incident Report for Swyftx
Resolved
This incident has been resolved.
Posted Jan 11, 2024 - 19:34 AEST
Investigating
Our team is currently aware of an issue impacting the processing of AUD withdrawals and are working, in coordination with our upstream banking providers, to resolve this issue.

Our team will provide an update on this issue as soon as more information becomes available. All affected withdrawals will be addressed and resolved periodically.
Posted Jan 11, 2024 - 19:30 AEST
This incident affected: AUD Withdrawals.