AUD and NZD pricing issue

Incident Report for Swyftx

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 17:18 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 18, 2025 - 15:58 AEST

Investigating

We're aware of an issue where AUD and NZD pricing appear to be frozen or showing as stagnant. Our upstream provider is actively investigating the issue. Rest assured, we are treating this with urgency and will provide you with an update at the earliest opportunity.
Posted Jul 18, 2025 - 15:56 AEST
This incident affected: Trading Website - trade.swyftx.com.