Balances not showing
Incident Report for Swyftx
Resolved
This incident has been resolved.
Posted Jan 12, 2024 - 16:07 AEST
Investigating
We are aware of an issue currently causing user balances and transactions to not display in some accounts, please note this is a display issue only and your balances are safe. Our development team is currently investigating this issue and are working on a fix with the highest priority.

We appreciate your patience and understanding and will provide an update on this situation shortly.
Posted Jan 12, 2024 - 15:22 AEST
This incident affected: Trading Website - trade.swyftx.com.