Crypto Withdrawal issue
Incident Report for Swyftx
Resolved
This incident has been resolved.
Posted Dec 14, 2023 - 19:36 AEST
Investigating
Our team has identified an issue affecting the processing of Crypto withdrawals off the platform. Our team is currently investigating the cause of this matter and are working to bring withdrawals back online, as soon as is safely possible.

We appreciate your patience and understanding.
Posted Dec 14, 2023 - 18:21 AEST
This incident affected: Crypto Withdrawals.