Crypto Withdrawals

Incident Report for Swyftx

Resolved

This incident has been resolved.
Posted Oct 11, 2025 - 13:36 AEST

Identified

Our wallet providers are experiencing degraded performance in crypto withdrawals. Withdrawals made during this time may be paused and/or delayed. We apologise for the inconvenience.
Posted Oct 11, 2025 - 08:08 AEST
This incident affected: Crypto Withdrawals.