Withdrawal verification email issue

Incident Report for Swyftx

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 22:22 AEST

Investigating

Our team is aware of an issue impacting delayed withdrawal verification emails. We are working as fast as possible to resolve this issue.
Posted Apr 22, 2025 - 20:34 AEST